Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RMS-LOG-ORA-00001: unique constraint (RMS.IG3CEEST3) violated NA EQUALIZAÇÃO DOS ALEATORIOS NA EQUALIZAÇÃO DOS ENDEREÇOS AO ENDERECAR


time.png Tempo aproximado para leitura: HH:MM:SS min

Ocorrência

Ao endereçar produto ocorre a mensagem abaixo:

 

mceclip0.png

Ambiente
Retail Manager System, V12.32, V22.01.

Causa
Devido a informações duplicadas de endereço , o sistema retona com o ORA-00001 Unique Constraint

Solução
Passo 1:  Realizar a consulta a consulta abaixo:

 

SELECT EES_DEPOSITO,
EES_GALPAO,
EES_RUA,
EES_NRO,
EES_APT,
REGISTROS
FROM(
SELECT EES_DEPOSITO,
EES_GALPAO,
EES_RUA,
EES_NRO,
EES_APT,
COUNT(EES_PROD_RESE_2) AS REGISTROS
FROM AG3CEEST
GROUP BY EES_DEPOSITO, EES_GALPAO, EES_RUA, EES_NRO, EES_APT
)

 


WHERE REGISTROS > 1;

 


Passo 2: Verificar no retorno da consulta as informações que estão duplicadas conforme exemplo abaixo:

mceclip1.png

Passo 3:

Realizar o backup, e logo após utilizar no final da consulta o 'FOR UPDATE' e deletar (Excluir) as informações que tiveram retorno na consulta, o select foi criado afim de trazer as informações duplicadas, logo após seguir novamente com o endereçamento do produto.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _