Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - FGL - Lentidão na emissão do Balancete ou Demonstrativo Contábil

time.png Tempo aproximado para leitura: 00:02:20 min

Ocorrência
Problema de lentidão na emissão dos relatórios de saldos:
FGL307AB - Balancete (prgfin/fgl/fgl307ab.r),
MGL204 - Demonstrativo Contábil (prgfin/mgl/mgl204aa.r).

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Contabilidade Fiscal (FGL) - Versão 12

Causa 
O problema pode ocorrer em função do volume de registros nas tabelas de controle dos Saldos  Contábeis, como também volume de registros nos cadastros de controle, como  Estabelecimentos e Unidade de Negócio, que variam em cada empresa. 

Solução
Testar se a função NOVA_LOGICA_DEMONST está ativa e medir o tempo de execução do balancete. 

1 - Ativar a geração do extrato de versão e fazer a emissão do Balancete parametrizando a opção Imprime Parâmetros.  

2 - No arquivo extrato de versão procurar por SPP_NOVA_LOGICA_DEMONST se constar como yes a função já está ativada. Na página de parâmetros do Balancete, procurar por Tempo Execução. 

Para melhorar a performance na emissão dos relatórios, ao executar o programa UFN906 - Função Liberação Especial (prgint/ufn/ufn906za.r),  a função NOVA_LOGICA_DEMONST pode ser mantida ativa ou desativada. Após alteração da parametrização do controle da função, voltar a ativar a geração do extrato e voltar a gerar o relatório Balancete. Comparar os tempos apresentados em cada execução para definir a ativação ou não da função. 

Caso não ocorrer redução do tempo de execução, encaminhar os anexos gerados e encaminhar para avaliação da equipe de Suporte Controladoria. Se o problema ocorre na emissão de demonstrativos o teste através da emissão do Balancete pode ser realizado, pois os programas utilizam a mesma rotina de leitura de dados. 

Saiba mais
Cloud - Linha Datasul - Geração de extrato de versão

Cloud - Linha Datasul - Geração de clientlog

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _