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RH - RM - Meu RH - Erro ao logar no Meu RH: Valor não pode ser nulo nome do parâmetro value

time.png Tempo aproximado para leitura: 00:04:57 min

Ocorrência
Na aplicação Meu RH realizar o login retorna a mensagem de erro: 500 - Valor não pode ser nulo. Nome do parâmetro: value

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH - Todas versões

Causa 
O erro é retornado por alguns fatores como a ausência da instalação do Portal RM, usuário utilizado ainda não possui validade para acesso e outros.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Verifique a versão instalada do RM e Portal RM do servidor do Meu RH e também das máquinas (clientes) que irão realizar acesso, para o correto funcionamento a mesma versão deve ser instalada em todas as máquinas. Caso necessário auxílio para verificar a versão dos ambientes o artigo a seguir orienta como realizar essa verificação: RH - RM - Meu RH - Como verificar Versão e Patch da Biblioteca RM e Meu RH

2. Caso os ambientes estejam todos na mesma versão com o Portal RM devidamente instalado, o erro é retornado quando a validade do Usuário que está realizando o login está em data futura, por exemplo:

  • Usuário com Início de Validade em 01/05/2022
  • Login sendo realizado na data de 25/04/2022

mceclip0.png

O acesso ocorre conforme a data atual e não verifica a competência do ambiente RM.

3. Para realizar o ajusta da validade do Usuário acesse o módulo Serviços Globais | Segurança | Usuários e edite o Usuário que está realizando acesso:

 

4. Verifique se dentro do arquivo RM.Host.Service.exe.config localizado em C:\TOTVS\CorporeRM\RM.Net existe a tag DEFAULTDB informando o alias no campo value, caso já exista a tag em seu arquivo, verifique se o campo value possui o mesmo alias utilizado no RM.

  • <add key="DEFAULTDB" value="CorporeRM" />

mceclip0.png


5. Por fim, o erro pode ser retornado também caso o Perfil de Acesso vinculado ao Usuário (Perfil de conexão ao banco de dados) esteja com o Usuário e Senha do Banco incorreto.
Essa configuração pode ser visualizada em Serviços Globais | Segurança | Usuários editando o usuário que retorna erro ao logar, edite seu Código de Acesso e informe um usuário e senha para conexão ao banco de dados.

 

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Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

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Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

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