Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice (Linha Protheus) - Sigafat - invalid macro source (SSYacc0105e: Error token failed, no valid token):(3.001.001) on A410TUDOK(MATV410A.PRW)


time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao confirmar o pedido, gera o erro: invalid macro source (SSYacc0105e: Error token failed, no valid token):(3.001.001) on A410TUDOK(MATV410A.PRW) 28/01/2022 17:19:27 line : 157

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Sigafat - Todas as versões

Causa
O erro ocorre por que o código da natureza está sendo passado como numérico e o mv_1dupnat recebe o conteúdo carácter, veja a chamada do mv_1dupnat sendo chamado no erro:
 
  Local 42: CMV1DUPNAT(C) :3.001.001



Solução
Por padrão, o parâmetro é preenchido com  SA1->A1_NATUREZ  e pode ser mudado para SC5->C5_NATUREZ , mas se vai apontar o código da natureza diretamente no parâmetro, coloque entre aspas ("3. 001.001"),desta forma, o erro deixará de ocorrer.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _