Tempo aproximado para leitura: 00:02:00 min
Ocorrência
Ao incluir ou alterar um registro no cadastro de cliente , utilizando a rotina crma980, ocorre o erro:
O campoA1_XXXX refira à pasta:5, mas não existe. on FWFORMFIELD:PREPAREFIELDS(FWFORMFIELD.PRW) 04/02/2022 16:14:28 line : 408"
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Sigafat- Todas as versões
Causa
O sistema reclama que o campo apontado não foi direcionado corretamente a pasta 5 do cadastro de cliente.
Por exemplo:
O campoA1_CONTATO2 refira à pasta:5, mas não existe. on FWFORMFIELD:PREPAREFIELDS(FWFORMFIELD.PRW) 04/02/2022 16:14:28 line : 408"
Neste exemplo acima , o sistema informa que o campo a1_contato2, campo de usuário, não está endereçado a pasta correta do cadastro do cliente, sendo necessário verificar a pasta correta e endereçar o campo.
Esta inconsistência pode ocorrer com qualquer campo ou tabela do sistema.
Solução
Verifique o X3_FOLDER do campo em questão, se está preenchido com uma pasta que não existe na tabela "Clientes (SA1)".
Segue abaixo a estrutura de pastas da SA1:

Pegando como exemplo, o campo padrão a1_contato, ele se encontra na pasta cadastrais:

Ajustando o campo na pasta correta, o erro deixa de ocorrer.
0 Comentários