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Ocorrência
Todos os agentes do AppServer Progress estão ocupados ou presos.
Ambiente
Framework - Framework (Linha Datasul) – Appserver - Todas as versões
Causa
O motivo geralmente acontece quando a quantidade de agentes é insuficiente ou estes estão ficando travados em alguma rotina.
Solução
É possível monitorar os agentes disponíveis/ocupados através do OpenEdge Explorer -> [Selecionar o appserver] -> Server Pool Control. Nessa tela pode-se consultar o status de cada agente, finalizar processos travados ou adicionar novos agentes de maneira online.
Monitore posteriormente o comportamento dos agentes. Respeitar o número de agentes máximo conforme a licença Progress contratada para o Appserver.
Se os agentes ficarem muito tempo em uso com status CONNECTED, é possível que alguma rotina esteja travando-os.
Utilize o comando progetstack para identificar o programa em execução, será gerado um protrace.numero_pid no diretório WRK do Progress.
comando > progetstack PID
Envie para a análise do Suporte o protrace gerado, também logs do Tomcat e do Appserver do horário simulado.
Saiba mais
Informações referentes a licenças Progress em Framework - Linha Datasul - TEC - Licenças Progress utilizadas pelo produto Datasul
Informações para a geração um progetstack Framework - Linha Datasul - TEC - Como gerar arquivo de protrace
Logs do Appserver em Framework - Linha Datasul - TEC - Alterar nível do arquivo de log no Appserver Progress
Logs do Tomcat em Framework - Linha Datasul - TEC - Onde encontrar o log do Tomcat
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