FAQs - Suporte técnico

RM - FOP - Integração RM Labore x BackOffice Protheus - General Error

time.png Tempo aproximado para leitura: 00:03:27 min

Ocorrência
No módulo da Folha de Pagamento, ao tentar realizar qualquer tipo de integração com o BackOffice Protheus retorna o erro General Error.

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões

Causa
O erro é apresentando devido à falha de comunicação entre o ambiente RM x Protheus por alguns tipos de fatores.

Solução

O erro abaixo pode acontecer em qualquer tipo de integração realizada entre o RM x BackOffice Protheus:

mceclip2.png

Para solucionar essa ocorrência, podemos seguir os passos abaixo:

1. Devemos verificar o endereço do Protheus que foi informado no ambiente. Caso seja utilizado EAI 1.0, podemos encontrar acessando o módulo Integrações | Integrações | Mensagem Única | Integração e editar o registro.

mceclip0.png

2. Caso seja utilizado o EAI 2.0, poderá localizar acessando o módulo Integrações | EAI 2.0 | Aplicativos:

mceclip1.png


3. O tipo de integração irá determina o caminho e onde será o preenchimento, o EAI 1.0 utilizamos somente o endereço WebService do Protheus, já no EAI 2.0 também é necessário informar o  endereço REST do Protheus.

Observe exemplos de URL a serem informados:

Endereço WebService do RM:

http://ip_da_máquina:porta/EAIService/IConWSEAIService

Endereço WebService do Protheus:

http://ip_da_máquina:porta/EAISERVICE.apw?WSDL

Endereço Rest do Protheus:

http://ip_da_máquina:porta/rest

4. Todo endereçamento ser realizado, pode ser necessário realizar a reinicialização dos serviços DBACESS e APPSERVER por parte do Protheus e Host da aplicação RM.

Saiba mais
Caso tenha interesse em conhecer ainda mais sobre a integração, clique aqui.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _