Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Totvs Backoffice Protheus - SIGACOM - Error log Nome de objeto 'SXI' inválido - Em Rotinas do módulo Compras


Ocorrência
Ao realizar a inclusão de um cadastro de fornecedor apresenta o erro abaixo:

THREAD ERROR ([7988], ti, DKT-102) 30/03/2022 11:33:51
: Error : 208 (S0002) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Nome de objeto 'SXI' inválido.
( From tMSSQLConnection::GetQueryFile )
Thread ID [3812] User [Administrador] IO [3277] Tables [73] MaxTables [73] Comment [MATA020 - TCPIP - ThreadID(7988)] SP [ ] Traced [No] SQLReplay [No] InTran [No] DBEnv [MSSQL/TOTVS12] DBThread [(SPID 59,60,62)] Started [30/03/2022 11:32:37] IP [127.0.0.1:1234] IDLE [ ] InTransact [ ] Memory [0] Running [ROP_QUERY for 0 s.] RCV [122645] SND [571795] TCBuild [20210202-20210930] TCVersion [21.1.1.0] ARCH [64] OS [WINDOWS] BUILD [RELEASE]
SELECT XI_EVENTID FROM SXI SXI WHERE SXI.XI_EVENTID = '036' AND SXI.D_E_L_E_T_= ' ' on __EXECSQL(APLIB300.PRW) 06/10/2021 13:57:35 line : 149

 

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Gestão de Compras - Todas as versões

Causa
O erro está  relacionado a não se estar encontrando como válida a tabela SIX do sistema no ambiente em questão. Esta tabela é do cadastro do programa CFGA040 (INscr. Event Viewer) do Configurador, e que também fica no menus dos módulos do Protheus.
O acesso pelo módulo Configurador é Ambientes / Cadastros / Inscr. Event Viewer. Nos demais módulos, a rotina está disponível em Miscelâneas / Inscr. Event Viewer.


Solução

1.  Login com o usuário Administrador e acesso exclusivo ao módulo Compras;

2.  Acesse a rotina: Miscelanea -> Inscr. Event Viewer;

3. Verifique se a tabela SXI foi criada no banco de dados, via Top Connect, ou no diretório System do ambiente;

4. Se a tabela SXI não for criada, reinicie o serviço de banco de dados e o DBAccess e repita as etapas 1, 2 e 3.

 

Para correção é necessário verificar se a tabela é aberta/criada corretamente, e fazendo um teste de inclusão e exclusão de um registro conforme o vídeo abaixo, e verificando se o erro persiste.

20220401_104306.gif

 

Caso ainda persista, realizar um teste reiniciando o DBAccess.

Verificar também se existe a tabela SXI do ambiente em questão, caso exista valide se possui um registro com o ID do evento 036 que é o que é mostrado no erro:

Se possuir o evento será necessário realizar processo de recriação desta tabela SXI, e realização de novos cadastros.

 

Saiba Mais :

PÁGINA CENTRALIZADORA COMPRAS 

Mais Artigos Materiais - Compras (SIGACOM)

 

 

 

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _