Ocorrência
Ao tentar abrir o programa VDEVDIGI, apresenta o erro informando que o movimento contábil está fechado. Não é possível efetuar Devoluções nesta data!

Erro no Log:

Ambiente
Retail Manager System - RMS - Todas as versões.
Causa
Esse problema ocorre por conta do parâmetro DEVCLINFIS que está cadastrado no VABUPARA, parâmetro 160, porém o cliente não utiliza agenda de devolução de itens sem cupom, ou utiliza mas não cadastrou no programa VDEVPAIN (Painel de Controle da devolução), por conta disso apresenta erro no momento que ele faz a consulta no banco para buscar ambas as tabelas.
Solução
Para resolver esse problema, é necessário confirmar com o cliente se ele utiliza agenda de devolução sem cupom fiscal.
No programa de devolução, caso queira poderão ser criadas 2 agendas para controlar entradas com cupons e sem cupons.
Se a agenda utilizada para devolução sem cupom for a mesma agenda utilizada para devolução com cupom, os parâmetros DEVCLIFIS/DEVCLINFIS, receberão os mesmos valores no parâmetro 1 que são os códigos das agendas, conforme imagem abaixo.

Se a agenda para devolução sem cupom for diferente da agenda de devolução com cupom, o parâmetros DEVCLIFIS/DEVCLINFIS, receberão os códigos de suas respectivas agendas, conforme imagem abaixo.

Se o cliente não utiliza agenda de devolução sem cupom, esse não deve ser cadastrado no VDEVPAIN (deixando em branco o campo código) e o parâmetro DEVCLINFIS não deve ser criado, se existir deve ser excluído.

Seguindo essas regras, não será reportado erro.
Documentação: https://tdn.totvs.com/pages/releaseview.action?pageId=274309777
0 Comentários