Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT - Reference counter overflow ( over 32700 ) na exportação da consulta genérica da SA1 em MVC



time.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência
Após mudar a chamada do cliente para mvc, usando crma980, ao exportar uma consulta genérica da SA1, ocorre o erro: 

Reference counter overflow ( over 32700 ) on tLocalEnv::IncRefs() in file C:\bamboo\xml-data\build-dir\TP11-OF19310-TECXWIN64\advpl\localenv.cpp at line 357 on FWFORMMODELSTRUCT:LOADTRIGGERS(FWFORMMODELSTRUCT.PRX) 22/03/2022 15:52:11 line : 516

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT - a partir da release 12.1.27.

Causa
O problema ocorria por conta da leitura da função PICCLI , usada para tratar CNPJ do cliente, quando buscado via crma980, onde foi ajustado para o carregamento dentro do Modelo MVC CRMA980.

Por conta desta função, também eram gerados lentidão na extração da consulta e travamento da consulta da tabela Sa1, corrigidos com este ajuste.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Baixe o último pacote de expedição continua do módulo Faturamento: SIGAFAT
2.Via VS-CODE, efetue a aplicação da atualização;
3. Reinicie o smartclient e refaça o processo.

Obs: O fonte MATV030 deverá estar com data igual ou superior a 08/03/2022 para que a correção ocorra.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _