Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice Protheus - SIGACOM - Erro log cadastro de fornecedor (MATA020) variable is not an object on MODELDEF(MATA020MBRA.PRW).


Ocorrência
Ao fazer alteração ou incluir um fornecedor aparece o erro log de início:

variable is not an object on MODELDEF(MATA020MBRA.PRW)

 

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Compras - Todas as versões

Causa
[Exemplo:
Esse incidente ocorre, pois a parametrização do sistema está incorreta para o Cálculo da Substituição Tributária na entrada de NF.]

Solução

Efetue o procedimento abaixo:

Favor verificar se não existe nenhum fonte chamado MATA020.PRW em seu repositório.

Caso tenha, por favor, descompile o mesmo, pois no repositório deve existir somente o MATA020.PRX com o nome de MATA020.

Se não tiver o arquivo MATA020.PRW em seu projeto para descompilar (excluir), basta criar um novo arquivo em branco no TDS ou IDE, salvá-lo com o nome de MATA020.PRW, jogar no seu projeto e descompilar.

Após este procedimento de descompilação (caso seja necessário), faça uma nova validação e veja se o erro foi corrigido.


Segue link do TDN com explicação: Pontos de Entrada MVC MATA020 na P12

 

Saiba Mais :

PÁGINA CENTRALIZADORA COMPRAS 

Mais Artigos Materiais - Compras (SIGACOM)

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _