Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Logix - OBF - OBF0030/SUP0007 - Erro VALOR NULL PARA COLUNA OBRIGATÓRIA DE TABELA no processamento

time.png Tempo aproximado para leitura: 00:01:15 min

Ocorrência
Erro VALOR NULL PARA COLUNA OBRIGATÓRIA DE TABELA no processamento.

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Logix) - Apuração Impostos - Versão 12

Causa
Este erro no processamento do OBF0030 ocorre porque na tabela termo_txt há um campo a mais campo ano_mes_referencia.

Solução
Para resolver este erro, devem ser realizados os procedimentos abaixo:

1. Executar os comandos SQL abaixo, para excluir o processamento do conversor do LOG6000.
delete from ctrl_alt_logix_2 where cod_sistema = 'VDP' and num_conversor = 2116;
delete from cnv_log_execucao where cod_sistema = 'VDP' and num_conversor = 2116;
delete from cnv_instr_realiz where cod_sistema = 'VDP' and num_conversor = 2116;

2. Processar o conversor VDP02116 pelo LOG6000, disponível no link: vdp02116.cnv

3. Executar o comando SQL para excluir o campo vago_1 da tabela termo_tx:

  • Banco de dados Oracle:
    ALTER TABLE termo_txt DROP COLUMN vago_1

  • Banco de dados Informix:
    ALTER TABLE termo_txt DROP vago_1

Após executados os procedimentos acima, os programas OBF0030/SUP0007 podem ser utilizados.

Glossário
OBF0030
- Processamento Apuração Crédito, Débitos e Saldo
SUP0007
- Textos Fiscais
LOG6000
- Gerenciador de Conversores de Layout de Tabelas
SQL -
Standard Query Language

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _