Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RMS - CRM - Erro na consulta de cliente CRM


Ocorrência
Ao tentar realizar uma venda de convenio do CRM pelo PDV, o mesmo apresenta erro abaixo.

Message: 'ORA-06550: line 2, column 1:
PLS-00306: wrong number or types of arguments in call to 'PROC_BUSCARCLIENTE'
ORA-06550: line 2, column 1:
PL/SQL: Statement ignored


Ambiente
Retail Manager System - RMS - Todas as versões.


Causa
O erro ocorre pois o PDV do cliente está fazendo as chamadas a esta package (PC_CRM_SRVCRM) com retorno em VARCHAR, quando deveria ser LCURSOR.

Neste caso especifico o erro foi na chamada da PC_CRM_SRVCRM.PROC_BUSCARCLIENTE, qual não existe mais as chamadas com retorno em VARCHAR.

 

Solução
Todas as chamadas externas a esta Package (PC_CRM_SRVCRM) deverão utilizar as Procedures com retorno em LCURSOR.

Sendo assim é necessário que o cliente entre em contato com o Software PDV, repassando a documentação abaixo para adequação ao nosso ERP.

Documentação: https://tdn.totvs.com/pages/releaseview.action?pageId=642408270

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _