Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - TECHFIN - Consignado - Erro na ativação Totvs App Consignado

time.png Tempo aproximado para leitura: 00:05:25 min

Ocorrência
Ao tentar realizar o processo de ativação do Totvs Consignado é apresentada a ocorrência, Erro no processo de ativação do projeto! Um ou mais erros. Erro ao enviar dados via Http! Ocorreu um erro ao enviar a solicitação. A solicitação foi anulada: Não foi possível criar um canal seguro para SSL/TLS.

Ambiente
RM – Folha de Pagamento  – A partir da versão 12.1.31

Causa
Esse incidente ocorre, pois o firewall está bloqueando os domínios utilizados pelo Totvs Consignado ou se trata de configurações de Firewall ou da GPO (group policy object) do servidor.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Verificar a liberação aos seguintes domínios pelo firewall.

https://totvs.rac.totvs.app

https://admin.rac.totvs.app
https://totvstechfin.carol.ai
https://provisioning.totvs.app

www.google.com

https://api-consignado.totvs.app
https://endpoint-registry.dev.totvs.app

 

O Firewall precisa liberar todos URLs que contenha "google.com", "totvs.app" e "caroi.ai" (portas 80 e 443), caso contrário pode dar erro de Timed out.

2. Habilitar TLS
Para ajustar basta criar um arquivo com a extensão .Reg e escrever o comando abaixo. Após criar o arquivo basta executar.

Importante que todos os servidores que processam Jobs estejam com essa configuração.

Atenção

Antes de Executar é importante fazer o backup das todas as chaves descritas no bloco de código.

Windows Registry Editor Version 5.00
; 0x00000008    Habilitar o SSL 2.0 por padrão
; 0x00000020    Habilitar SSL 3.0 por padrão
; 0x00000080    Habilitar TLS 1.0 por padrão
; 0x00000200    Habilita o TLS 1.1 por padrão
; 0x00000800    Habilitar TLS 1.2 por padrão
 
 
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp]
     "DefaultSecureProtocols"=dword:0x00000800
 
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp]
     "DefaultSecureProtocols"=dword:0x00000800
 
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client]
 "DisabledByDefault"=dword:00000000
  
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Server]
 "DisabledByDefault"=dword:00000000

 

2.1 Ferramentas de teste de solução de problemas de conexão SSL / TLS (Totvs App precisa de TLS1.2 handshake)

 

Existe um troubleshooting da Microsoft abordando diversas formas de se testar a comunicação:

https://techcommunity.microsoft.com/t5/azure-paas-blog/ssl-tls-connection-issue-troubleshooting-test-tools/ba-p/2240059

 

Utilizando CURL

curl -v https://endpoint-registry.dev.totvs.app/api/v1/services --tlsv1.0

curl -v https://endpoint-registry.dev.totvs.app/api/v1/services --ciphers ECDHE-RSA-NULL-SHA --tlsv1.2

Resposta esperada (Sucesso)

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _