Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Linha RM - FIN - Erro ao abrir o RMLiber.exe - 'XX/XX/XXXX' não é uma data válida.

Ocorrência

Ao tentar alterar a coligada no RMLiber .exe o sistema apresenta a mensagem abaixo:

"12/31/XXXX' não é uma data válida"

Ambiente
Cross Segmentos - Backoffice Linha RM - Totvs Gestão Financeira - Todas as versões

Causa
Esta mensagem é exibida devido a configuração da tag  "LocalizationLanguage" disponível nos arquivos  RM.Host.exe.config, RM.Host.JobRunner.exe onde determina a linguagem como en-(US). 

Desta forma as datas serão armazenadas no banco de dados no formato americano MM/DD/AAAA porém o RM não trabalha com data neste formato.

Solução

Para solucionar essa ocorrência, realize os seguintes passos:

 

1. Abrir os arquivos RM.Host.exe.config e RM.Host.JobRunner.exe.config e realizar alteração da tag <add key="LocalizationLanguage" value="en-US" /> para a tag abaixo

 

<add key="LocalizationLanguage" value="pt-BR" />

 

Conforme exemplo abaixo:

 

 

 

Observação:  Esta alteração deve ser realizada em todas as máquinas que possui a instalação do RM quando ambiente local e/ou nos servidores de aplicação e servidores de job quando ambiente N camadas.

 

2. Encerrar o RM, acessar a pasta c:/totvs/corpore rm/rm.net, localizar e excluir o arquivo _broker.dat e reiniciar o host.

 

3. Acessar os parâmetros dos Módulos Gestão Contábil e Gestão Financeira e avançar em todas as etapas até concluir o processo conforme abaixo com a finalidade de regravar as datas no banco de dados.

Acesse o módulo Gestão Contábil | ambiente | parâmetros | Totvs Gestão Contábil | e "avançar" em todas as etapas.

 

 

​Acesse o módulo Gestão Financeira | Ambiente | Parâmetros | Totvs Gestão Financeira | e "avançar" em todas as etapas.

 

 

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _