FAQs - Suporte técnico

Cross Segmentos - Backoffice Protheus - SIGAFAT - Numeração Automática no Código do Cliente (A1_COD) ao copiar um cadastro

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Ao copiar o cadastro de cliente/fornecedor não preenche o código de cliente automático.

Ambiente
Cross Segmentos - Backoffice Protheus - SIGAFAT - Todas as versões

Causa
As funções GetSXENum e GetSX8Num não existem por padrão no campo de Código do Cliente (A1_COD), alguns clientes inserem a validação manualmente, porém algumas particularidades não são tratadas pela função, veja mais detalhes em "Passo 2 - Função no Dicionário" no link:

Solução
A orientação da TOTVS, conforme documentação citada acima, é que seja utilizada uma função customizada para tratar o controle de numeração, apenas com a inserção das funções GetSXENum e GetSX8Num, em alguns cenários, podem ocorrer erros no controle de numeração.

Abaixo indicamos um exemplo de função, lembrando que trata-se apenas de um exemplo, caso necessite customizar, solicite o acompanhamento de seu analista programador:

#Include 'TOTVS.ch'

User Function NextSA1Cod()
Local cNum := GETSXENUM("SA1","A1_COD")

DbSelectArea("SA1")
SA1->(DbSetOrder(1))
While (DbSeek(xFilial("SA1")+cNum))
ConfirmSX8()

cNum := GETSXENUM("SA1","A1_COD")
Enddo

DbCloseArea()
RollbackSx8()
Return cNum


Saiba mais:

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _