FAQs - Suporte técnico

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATA330 - type mismatch on compare on MA330FOK(MATA330.PRX)


Ocorrência
Ao executar o recálculo do custo médio - MATA330, o sistema retorna com o error.log type mismatch on compare on MA330FOK(MATA330.PRX)

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.

Causa

A Função MA330FOK ->Checa marcação das filiais para calculo por empresa e a integridade dos parâmetros entre as filiais.

Analisando o fonte podemos verificar que a função MA330FOK, tem como funcionalidade comparar os parâmetros descritos na imagem abaixo, e caso tenha alguma divergência, apontar na forma de um help. 



Solução

1.  Realizar um teste configurando a pergunta "Cálculo de Custos por?" para "Selec. Filiais" e selecionar apenas uma filial por vez e verificar se o erro é reproduzido. 

2.Notando que ao selecionar uma filial por vez, o erro não ocorre, verificar se todos as filiais esta com o parâmetro MV_ULMES corretamente preenchidos e os demais parâmetros:

MV_CQ, MV_CUSTEXC, MV_CUSFIFO, MV_CUSFIL, MV_CUSMED, MV_CUSZERO, MV_FIFOENT, MV_GERIMPV, MV_LOCPROC, MV_NGMNTPC, MV_NGMNTCM, MV_NGMNTES, MV_PRODPR0, MV_M330THR.

3.  Neste exemplo, foi deixado o parâmetro MV_ULMES com datas diferentes entre duas filiais, o sistema retornou a mensagem, "Atenção: Diferença no parâmetro MV_ULMES''.

 

Saiba mais: 
Clique aqui e veja mais artigos sobre Custos no Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _