Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

WINT - Código de barras inválido no campo 04 - código de barras, no registro 0220

time.pngTempo aproximado para leitura: 00:01:00 min

Dúvida

Ao tentar gerar o Sped Fiscal na rotina 1097 é apresentada a mensagem Código de barras inválido, sobre o campo 04 - código de barras, no registro 0220?

mceclip0.png

Ambiente
TOTVS Distribuição Linha Winthor - 14 - Faturamento -  A partir da versão 30

 

Causa

Este erro ocorre por conta de uma nova validação do SPED do LAYOUT 16, onde se existir o registro 0220, é feita uma validação entre ele e o registro 0200. Quando observamos o Guia prático o registro 0220 trouxe uma alteração no campo 4 que antes não existia. Agora este registro também tem o campo código de barras, assim como também tem no registro 0200. Quando há o registro 0220 é feita uma nova validação, onde este registro faz uma verificação do registro 0220 que deve estar no padrão da GS1, ou seja, conter os caracteres de 8, 12, 13 ou 14, seguindo a regra conforme cadastro da rotina 203
Seu cadastro não deve estar conforme a legislação e dessa forma nos orientamos que você efetue as correções, conforme o código de barras registrado na GS1, ou se seu produto não tiver, verificar com a contabilidade qual informação deve ser inserida.
1. Os campos 04 (que são os campos de código de barras dos dois registros) não podem ser iguais - e devido a esta validação, não geramos o código de barras no Registro 0220 - é um campo facultativo;
2. O Registro 0200, se enviado um GTIN 8, 12, 13 ou 14, precisa ser um GTIN válido pela GS1. Conforme o guia prático do Sped Fiscal abaixo:
mceclip1.png
Solução 
Para efetuar a correção abra a sua rotina 203 e prossiga da seguinte forma:
1. Efetue a pesquisa do produto em que está ocorrendo o erro;
2. Dentro do cadastro procure os campos GTIN e preencha-os com o GTIN válido ou deixe-os nulo;
 
mceclip0.png

3. Gere você pode gerar o Sped Fiscal novamente e este produto terá sido corrigido.
Importante: estes campos de GTIN são validados para sua NF-e também, por isso é necessária muita atenção ao efetuar o preenchimento.
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _