Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RMS - INV - Problemas ao executar critica de inventário - Erro critica_lote


Ocorrência

Ao criticar inventário ocorre o erro abaixo:

mceclip1.png


Ambiente
Retail Manager System - R32 e R22

Causa
Foi verificado que ao utilizar os números de lote padrão, que vem carregado nos campos "Lote Inicial = 0 e Lote Final = 9999" e executar o processo de crítica para geração do relatório o sistema apresenta o erro de "number precision too large", onde o campo excede o tamanho. (Teste realizado no cliente).

 

Ao utilizar/digitar um número de "Lote Final" menor (exemplo 999, 8999) o problema não ocorreu e é apresentado o relatório sem a apresentação do erro informado.

No código da pc_critica_inventario, critica_lote, é verificado no Passo 18 que a variável "V_NFICHA_VERIF := V_NFICHA_VERIF +

 

No código da pc_critica_inventario, critica_lote, é verificado no Passo 18 que a variável "V_NFICHA_VERIF := V_NFICHA_VERIF + 1;" não está suportando a quantidade definida no lançamento do "Lote Final" da pesquisa.

Independente de cair no "IF" ou no "Else" é somado + 1 a cada passagem realizada por esta variável.



Solução

passo 1;

Isso não impede o uso do sistema desde que, o cliente consiga informar o número de lote final de acordo com o necessário. Porém, o ideal é verificar a variável e o campo utilizado para ser aumentada a capacidade para a quantidade padrão informado pelo sistema, para não ser apresentado o erro.


passo 2;

 

Foi concluído totalmente o inventário, com a atualização através do sistema sem a apresentação de problemas.


passo 3.

 

Foi informado ao usuário que caso venha acontecer o problema novamente, para que ela executa-se o mesmo processo, onde:

Excluir a importação do inventário;
Importar novamente;
Criticar com o campo Lote Final com uma numeração inferior ao aplicado como padrão pelo sistema (9999), conforme citado acima.

 

 Ao realizar o procedimento acima, foi utilizada a quantidade de Lote Final padrão do sistema (9999) e o mesmo não apresentou erro.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _