Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

CNFE - RMS - ERRO : ORA-00001 : Unique constraint (RMS.IFE_CONTROLE_SAIDA1) violated



time.png Tempo aproximado para leitura: 03:00:00 min

Ocorrência

No módulo do ConectorNFe, ao tentar gerar XML's  é apresentada a mensagem ERRO : ORA-00001 : Unique constraint (RMS.IFE_CONTROLE_SAIDA1) violated

mceclip0.png

Ambiente

RMS - ConnectorNFe  - Todas as versões

Causa

O erro apresentado acontece porque o processo está tentando inserir um id que já existe.
O next number da sequence SEQ_NFE_CONTROLE_SAIDA, tem que ser maior que o max(ID) da  tabela NFE_CONTROLE_SAIDA.


Solução

Para solucionar essa ocorrência, realize os seguintes passos:

1. Execute as duas consultas abaixo: 

1.1 - select max(id) from NFE_CONTROLE_SAIDA 
1.2 - select seq_nfe_controle_saida.NEXTVAL AS SEQUENCE FROM DUAL

1.1 - CONSULTA

mceclip1.png

1.2 - CONSULTA

mceclip2.png


2. Para resolver será necessário editar a SEQUENCE, duplo click na SEQUENCE > BOTÃO DIREITO > EDIT;

mceclip3.png
3. Alterar o next number informando maior do que o max id da nfe_controle_saida 

Ex:  (491284 + 10 = 941294) – colocar 941294 no Next numbermceclip4.png

4. Após alteração clicar em "APLLY" e validar 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _