Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - GPE - Erro validador DIRF 2022 "Registro não está de acordo com o leiaute do arquivo de importação


time.png
Tempo aproximado para leitura: 00:01:00 min

Ocorrência

Ao importar o arquivo magnético da DIRF 2022 para o validador, o seguinte erro é apresentado:
Registro não está de acordo com o leiaute do arquivo de importação - Não foi encontrada sequencia valida de registros DIRF + RESPO + DECPJ + ou DECPF no inicio do arquivo.
Conteúdo 2022/VR4QLM8.

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal – A partir da Versão 12.

Causa
O problema ocorre pois o ambiente não esta atualizado para a DIRF 2022, dessa forma, no arquivo magnético é gerado o identificador de estrutura de layout de anos anteriores, e ao importar no PGD 2022, o erro é apresentado.
mceclip1.png

Solução
Para solucionar essa dúvida, realize os seguintes passos:
1. Aplique o pacote de atualização para DIRF;
2.
Gere a DIRF novamente no menu GPEM550;
3.
Gere novamente o arquivo magnético na rotina GPEM590;
4.
Verifique na linha 1 se o registro passou a ser XJFSFHB;
5.
No arquivo magnético a primeira linha deve ficar DIRF|2022|2021|N||XJFSFHB


Para acessar o pacote de expedição continua do RH, clique no link: https://suporte.totvs.com/portal/p/10098/download#all/all/all/search/rh_expedicao_continua 


Saiba Mais:
RH-DIRF 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _