Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS Construção - Obras e Projetos - TCOP - Problema na Integração EAI: Exception has been thrown by the target of an invocation AUTHENTICATION: USER NOT AUTHORIZED


time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
No módulo de Obras e Projetos, ao tentar realizar a integração de um item com BackOffice Protheus na versão 12.1.33 é apresentada a mensagem de erro: Exception has been thrown by the target of an invocation AUTHENTICATION: USER NOT AUTHORIZED:
img2.png

Ambiente
TOTVS Construção - Obras e Projetos - EAI 2.0 com a versão 12.1.33 do Protheus.

Causa
Este incidente ocorre pois houve uma alteração de comportamento na autenticação dos WebServices SOAP e REST a partir da release 12.1.33 do Protheus.
A partir desta versão, caso a chave Security não seja informada no arquivo appserver.ini, os serviços serão iniciados exigindo autenticação de usuário.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Para que o sistema faça a verificação da autenticação de forma correta, é recomendado que configure a chave de segurança dos serviços com o valor 1. Exemplo: Security=1.

2. Acesse o RM - Integração - EAI 2.0 - Acesse o Aplicativo da Integração;

3. Configure um usuário e senha para os endereços de WebServices SOAP e REST:
img1.png

4. Salve as alterações e faça um novo teste de integração.

Importante: O usuário de aplicação configurado deverá ser um usuário do Protheus com permissões no módulos que a integração utilizará:
mceclip5.png

 

Observação: Caso seja necessário trabalhar sem autenticação, a chave deverá ser configurada com o valor 0 no appserver.ini do Protheus. Exemplo: Security=0.

 

Saiba Mais
Configurar Portais e Webservices
Configuração de WebServices REST

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _