Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - MDT - Error log ao efetuar a transferência de ficha médica - Error : 156 (37000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Sintaxe incorreta próxima à palavra-chave 'WHERE'.

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao tentar efetuar a transferência de ficha médica, através da rotina MDTA970, gera error log: "Error : 156 (37000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Sintaxe incorreta próxima à palavra-chave 'WHERE'.
( From tMSSQLConnection::GetQueryFile )
Thread ID [8884] User [Administrador] IO [11958] Tables [61] MaxTables [62] Comment [MDTA970 - TCPIP - ThreadID(12928)] SP [ ] Traced [No] SQLReplay [No] InTran [No] DBEnv [MSSQL/P1227] DBThread [(SPID 52,59,54)] Started [03/12/2021 11:27:33] IP [127.0.0.1:2590] IDLE [ ] InTransact [ ] Memory [0] Running [ROP_QUERY for 0 s.] RCV [170854] SND [1126095] TCBuild [20210202-20210930] TCVersion [21.1.1.0] ARCH [64] OS [WINDOWS] BUILD [RELEASE]
SELECT X2_PATH FROMWHERE X2_CHAVE = 'TM0' on __EXECSQL(APLIB300.PRW)"

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Medicina e Segurança do Trabalho - Todas as versões

Causa
O erro ocorre em ambientes com o fonte MDTA970 com data igual ou anterior a 26/11/2021 

Solução
Para correção do erro, é necessário aplicação do pacote abaixo:
12.1.17:https://suporte.totvs.com/portal/p/10098/download?e=1058225 ; 12.1.27:https://suporte.totvs.com/portal/p/10098/download?e=1058226 ; 12.1.33:https://suporte.totvs.com/portal/p/10098/download?e=1058227 ;

Obs.: Devido ao Ciclo de Vida de Software TOTVS estipulado e a data da expedição desta correção (06/01/2022), esta correção não estará disponível para a versão 12.1.25:
https://tdn.totvs.com/display/public/PROT/Ciclo+de+Vida+de+Software+-+TOTVS+Linha+Protheus 


Informações complementares
Pacote de Expedição Contínua do RH: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854
Pacote de Expedição Contínua do eSocial:https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854 
Pacote de Expedição Contínua do Medicina e Segurança do Trabalho:https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057956773 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _