Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS CRM Automação de Força de Vendas (SFA) - WEB - Integração - Erro na requisição do webservice para causa de credenciais inválidas


time.png Tempo aproximado para leitura: 00:20:00 min

Ocorrência
Ao identificar que não está integrando as informações no MasterSales, e identificar no log o erro "

Abort.0 - ERROR (version 8.0.0.0-28, build 8.0.0.0-28 from 2017-11-05 07.27.50 by buildguy) : Erro na requisição webservice", uma das causas pode ser as credenciais que a integração utiliza entre o CRM e o plugin.



Ambiente
Cross Segmentos - TOTVS CRM Automação de Força de Vendas (SFA) - WEB - Integração - Todas as versões

Causa
Erro na requisição do webservice

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
Passo 1:

Ao analisar o log da integração e identificar o erro abaixo:

mceclip0.png

Obs: onde está em vermelho está apresentando o IP e porta do plugin.

Indica que a integração não está conseguindo conectar com o plugin.


Passo 2;

Copiar o caminho do webservice, que está no log, abrir o Postman, colar o mesmo no campo GET e após clicar em Send;

mceclip1.png

Se aparecer a mensagem abaixo, significa que a senha no ERP está diferente da integração.

{"message":"The request requires authentication. The server might return this response for a page behind a login."}


Passo 3;

Acessar a pasta de instalação do MasterSales, que pode ser C:\ws\integracao_spoon\producao\config\.kettle - Informar o diretório e o nome da pasta raiz, que geralmente é ws ou sim3g;

Abrir o arquivo "kettle.properties" com um editor de textos, localizar no mesmo a opção "TOKEN PARA REQUISIÇÕES", copiar o token que está informado na opção, sem a palavra Basic.

mceclip3.png

 

Passo 4;

Tendo o token em mãos, acessar o site: https://www.base64encode.org/

Selecionar a opção "Decode", conforme print:

mceclip4.png

No primeiro quadrado colar o token, copiado conforme passo 3, e clicar no botão "Encode", onde aparecerá no campo abaixo o usuário e senha, na sequencia, separados por ":"

mceclip5.png

 

Passo 5;

Com as credenciais em mãos ajustar os mesmos no ERP, e após testar a integração novamente, onde a mesma irá executar corretamente sem apresentar o erro.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _