Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Erro ao utilizar SetValue da classe TWsdlManager.

time.png Tempo aproximado para leitura: 00:01:45 min

Ocorrência
Utilizando o método SetValue da classe TWsdlManager para preenchimento de parâmetros em um webservice, o XML apresenta falha abaixo na resposta do servidor:

Error: elemento inesperado...Os elementos esperados

Exemplo de erro utilizando o API dos Correios:

<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Body><soap:Fault><faultcode>soap:Client</faultcode><faultstring>Unmarshalling Error: elemento inesperado (uri:"http://cliente.bean.master.sigep.bsb.correios.com.br/", local:"cep"). Os elementos esperados são &lt;{}cep> </faultstring></soap:Fault></soap:Body></soap:Envelope>


Ambiente

Cross Segmento - TOTVS Backoffice (Linha Protheus) – ADVPL – Todas as versões

Causa
A falha ocorre pois, a API neste caso necessita do prefixo de namespace antes dos nomes das tags na mensagem SOAP.

Solução
Utilize a propriedade lUseNSPrefix, para enviar o namespace.
oWsdl:lUseNSPrefix := .T.

Saiba mais
lUseNSPrefix

TWsdlManager 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _