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Ocorrência
Ao efetuar a importação do XML pelo Importador XML ou TOTVS Colaboração é gerado o registro no arquivo "deliveryxml_salesorder" o help A410NATCLI ou A410NATPED.
Ambiente
Cross Segmentos - Backoffice Protheus - SIGAFAT - a partir da release 12.
Causa
O problema ocorre quando o campo A1_NATUREZ não está com a natureza informada no cadastro do cliente no momento da integração do pedido de venda por job MATA411.
- Caso o parâmetro (MV_1DUPNAT = SA1->A1_NATUREZ) será apresentado o Help A410NATCLI.
- Caso o parâmetro (MV_1DUPNAT = SC5->C5_NATUREZ) será apresentado o Help A410NATPED.
Obs.: As divergências de integração do pedido serão geradas nos arquivos "order" e "deliveryxml_salesorder" dentro da pasta XML, criada na pasta System.
Solução
- Help A410NATCLI (MV_1DUPNAT = SA1->A1_NATUREZ)
Altere o cadastro do cliente utilizado para a integração e selecione via consulta [F3], a natureza que deverá ser utilizada no campo A1_NATUREZ;
Salve a alteração e posteriormente efetue a atualização da tarefa schedule para que o sistema processe o XML para integração do pedido de venda (MATA411).
- Help A410NATPED (MV_1DUPNAT = SC5->C5_NATUREZ)
Por padrão na integração do pedido de venda (MATA411), o sistema sempre utilizará a natureza que está cadastrada no cadastro do cliente (A1_NATUREZ).
Nesse caso temos duas opções:
1 - Altere o cadastro do cliente utilizado para a integração e informe uma natureza válida que deverá ser utilizada no campo A1_NATUREZ.
Salve a alteração e posteriormente efetue a atualização da tarefa schedule para que o sistema processe o XML para integração do pedido de venda (MATA411).
2 - Caso não queira utilizar a natureza no cadastro do cliente, poderá customizar por meio do ponto de entrada MA411GRV e informar a natureza no campo C5_NATUREZ:
MA411GRV - Manipula os dados do pedido de vendas gerado através do EDI de Vendas (TOTVS Colaboração)
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