Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT - Ajuda: Regnois - Não existe registro relacionado a chave informada no alias SE4, ordenação 1


time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao efetuar  a importação do XML pelo Importador XML é gerado o registro no arquivo deliveryxml_salesorder: Ajuda: Regnois - Não existe registro relacionado a chave informada no alias SE4, ordenação 1.

mceclip0.png

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Sigafat -a partir do release 12.1.25.

Causa
O problema ocorre por que o XML está indicando uma determinada condição de pagamento e a mesma não existe no cadastro de condições de pagamento (SE4), no índice 1 que é Filial+código.

Neste exemplo, veja que tag de condição de pagamento "conditionpay", está sendo apontado a condição 001 e vejam que no arquivo deliveryxml_salesorder, indica justamente que a informação de condição de pagamento 001 que está inválida, facilitando na análise do problema, se é o caso de criação da condição ou o ajuste do XML para a condição correta:

mceclip1.png

mceclip2.png

Solução

Para solucionar essa ocorrência, realize os seguintes passos:
1. Verifique a condição de pagamento que o XML está tentando integrar e certifique-se que a mesma existe no cadastro de condição de pagamento (SE4);

2. Caso não exista a condição indicada, crie a condição de pagamento (MATA360) e posteriormente, efetue a atualização da tarefa schedule para que o sistema processo o XML para integração do pedido de venda (Mata411);

3. Caso a informação da condição de pagamento esteja incorreta no XML, ajuste a tag  conditionpay para o código da condição de pagamento correta, e posteriormente efetue a atualização da tarefa schedule para que o sistema leia o XML novamente, processando a integração.

Obs. as divergências de integração do pedido serão geradas nos arquivos Order e deliveryxml_salesorder dentro da pasta XML, criada na pasta System.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _