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Varejo - Supermercados - C5Navigant - MAC: 02:00:00:00:00:00 causando concorrência de sessões no banco, ocorrendo no travamento dos coletores

time.png Tempo aproximado para leitura: 00:10:00 min


Ocorrência
Ao realizar algum processo no Consinco ALW, está sendo retornado alguns erros em tela nos coletores:

mceclip0.png

mceclip2.png

Ambiente
Em todos os Coletores com o Sistema Operacional Android, nas Versões 19.07, 20.01 e 21.01

Causa
Esse incidente ocorre na maioria das vezes, devido a falta de atualização da aplicação C5Navigant.apk nos Coletores Android.

mceclip1.png

No exemplo acima, pode-se notar que o identificador de MAC encontra-se como 02:00:00:00:00:00 (fixo), fazendo portanto que todos os coletores ocorram algum tipo de problema, pois quando estiver fixo 02:00:00:00:00:00 o mesmo estará concorrendo com a sessão dos demais coletores e provocará em uma parada em alguns ou todos os coletores.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:


1. Verifique qual a PTF e Versão do C5Navigant que encontra-se nos Coletores.

Como no exemplo que segue abaixo, temos a foto do painel de configurações do C5Navigant.apk, onde podemos notar que o C5Navigant encontra-se na 19.07.001:

mceclip2.png


2. Verificar qual a PTF e Versão Atual do Banco de Dados e pegar no Pacote de Atualização > Aplicativos o C5Navigant.apk da PTF e Versão correspondente

Como exemplo, utilizei o C5Navigant.apk da PTF e Versão 19.07.001

Caminho que encontra-se o C5Navigant: PACOTE_COMPLETO_19_07_001.ZIP\Aplicativos\UTL_C5NAVIGANTI_19_07_001.ZIP

mceclip3.png

Ao identificar o C5Navigant.apk, copie o arquivo e cole em todos os coletores Android que estão com problemas do MAC e posteriormente, realize a instalação do mesmo nos coletores para que o C5Navigant.apk fique atualizado.

Pode-se verificar que após a instalação, o C5Navigant ficou com a PTF e Versão atualizada:

mceclip3.png

 

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