Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - GPE - Error log ao tentar gerar opções do Relatório de Rescisão - InterFunctionCall: cannot find function GPER994

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao tentar utilizar as opções de Impressão do Relatório de Rescisão, através da rotina GPER140, é gerado error log: "InterFunctionCall: cannot find function GPER994 in AppMap on IMPFUNC(GPER140.PRX)".

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal - Todas as versões.

Causa
Este erro ocorre devido à falta de compilação dos RDMakes IMPRESZ, IMPRESG, IMPRESC, IMPRESH e/ou IMPGRFC.
Cada falta de RDMake gera um error log, conforme abaixo:
   -> InterFunctionCall: cannot find function GPER994: RDMake IMPGRFC 
   -> InterFunctionCall: cannot find function GPER999: RDMake IMPRESC 
   -> InterFunctionCall: cannot find function GPER1000: RDMake IMPRESG 
   -> InterFunctionCall: cannot find function GPER1001: RDMake IMPRESH 
   -> InterFunctionCall: cannot find function GPER1002: RDMake IMPRESZ 

Solução
1. 
Compilar os RDMakes IMPRESZ, IMPRESG, IMPRESC, IMPRESH e IMPGRFC disponibilizados no diretório "RDMakes" do pacote de Expedição Contínua do RH:
Pacote de Expedição Contínua do RH: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854 

Saiba Mais:

Documentação técnica sobre a implementação: https://tdn.totvs.com/pages/releaseview.action?pageId=644718698 
Como compilar fontes: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360019132991 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _