Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

WINT - ORA-04030 of process memory when trying to allocate XXXX bytes.

WINT - ORA-04030 of process memory when trying to allocate XXXX bytes.

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
O que fazer quando a rotina apresentar o a mensagem ORA-04030 of process memory when trying to allocate XXXX bytes.

JyjM6PerkOd4ZFrfHdADZr7PU (1036×135)

Ambiente
TOTVS Distribuição Linha Winthor - 25 - Integrações -  A partir da versão 30


Causa
ORA-04030 pode ser causado por uma falta de RAM em um ambiente dedicado (servidor não compartilhado), um PGA muito pequeno e por não definir parâmetros de kernel grandes o suficiente para permitir RAM suficiente. O ORA-04030 também é comum ao executar uma importação


Solução
Para resolver essa mensagem, acione o TI ou DBA para que ele verifique o ambiente. 

 

Saiba mais

Consulte dicas de importação de erros ORA-04030. Confira também a Nota MOSC 233869.1 intitulada "Diagnosticando e resolvendo erros do ORA-4030".

Essencialmente, o ORA-04030 é claro e é um erro de "memória fora do processo", pelo qual o Oracle não pode obter a RAM necessária para concluir as operações. Dependendo da versão do Oracle, você tem várias opções:

  • Aumentar pga_aggregate_target

  • Diminua sort_area_size e / ou hash_area_size

  • Mover para um servidor multi-thread (também conhecido como MTS ou servidores compartilhados)

Kernel Parms - (Karpinski, Joseph E) Ao instalar o Oracle 10G, encontramos vários problemas ORA-4030.

Alteramos a configuração de "ulimit" da seguinte maneira para resolver o problema:

ulimit –a
tempo (segundos)
arquivo ilimitado (blocos)
dados ilimitados (kbytes)
pilha ilimitada (kbytes) 4194302
memória (kbytes)
coredump ilimitada (blocos)
nofiles ilimitados (descritores) 4096 Também faz parte da lista de verificação de pré-instalação do Oracle 10G: Seção "ULimits OK?"

 

Para obter mais informações sobre como ajustar a classificação, consulte estas páginas:

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _