Tempo aproximado para leitura: 00:2:15 min
Ocorrência
Na rotina de Importação de Extrato Bancário - prgfin/cmg/cmg704aa.r ocorre o erro 2651 - Faixa de Datas Incorreta - A data inicial 10/05/14 deve ser menor ou igual a data final 01/05/14
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Datasul) - Caixa e Bancos (CMG) - Versão 12
Causa
Como a própria mensagem informa, a data inicial ficou maior que a data final por isto ocorre o erro.
Solução
O programa de importação busca a data inicial e final do arquivo que está sendo importado conforme foi parametrizado no Layout Extrato - prgfin/cmg/cmg010aa.r informado para importação.
Deve ser verificado as posições no layout disponibilizado pelo banco, os prints abaixo são apenas para exemplificar.
Primeiro ele irá buscar a data inicial e final pelas posições que foram parametrizadas nos registros de Sdo Inicial e Sdo Final nos campos abaixo

A data inicial é importada do arquivo conforme parametrização dos campos Dia Sdo Inicial, Mês Sdo Inicial e Ano Sdo Inicial.
No exemplo abaixo estamos informando que:
- O Dia da data inicial está nas colunas 81 até 82.
- O Mês da data inicial está nas colunas 83 até 84.
- O Ano da data inicial está nas colunas 85 até 86.

A data final é importada do arquivo conforme parametrização dos campos Dia Sdo Final, Mês Sdo Final e Ano Sdo Final.
No exemplo abaixo estamos informando que:
- O Dia da data final está nas colunas 81 até 82.
- O Mês da data final está nas colunas 83 até 84.
- O Ano da data final está nas colunas 85 até 86.

Caso os registros de Sdo Inicial e Sdo Final não estejam parametrizados no layout o programa irá assumir como data inicial a data do primeiro movimento que foi importado e a data final será a data do último movimento importado.
Com isto o erro 2651 - Faixa de datas incorreta! ocorre pois:
- os campos de data do layout estão parametrizados incorretamente no programa Layout Extrato - prgfin/cmg/cmg010aa.r. Verificar se os campos estão parametrizados conforme o layout disponibilizado pelo banco.
- ou o arquivo que está sendo importado não está compatível com o layout que foi cadastrado. Solução: verificar se o arquivo que está sendo importado é mesmo o arquivo correto - abrir o arquivo em um bloco de notas e verificar as posições dos campos que foram parametrizados, se for o arquivo correto verificar com o banco pois o arquivo não está compatível com o layout.
Outros motivos que podem causar problemas na importação:
- o arquivo possui mais de uma linha em branco no final ou não possui uma linha em branco no final. Para que o programa importe corretamente o arquivo o mesmo deve possuir somente uma linha em branco no final. Isto pode ser verificado ao abrir o arquivo em um editor de textos.
- o layout é de 200 posições e o usuário está importando um arquivo de 240 posições. Para verificar o tamanho do arquivo abrir o mesmo em um editor de textos e verificar quantas colunas o mesmo possui.
0 Comentários