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Cross Segmentos - TOTVS CRM Automação de Força de Vendas (SFA) - Android - Consulta - Pedido não aparece no SFA Android

time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência

O pedido foi finalizado e exportado para o ERP, porém não aparece no SFA android.


Ambiente
Cross Segmentos - TOTVS CRM Automação de Força de Vendas (SFA) - Android - Consulta - Todas as Versões

Causa
Uma das razões pelas quais esse problema ocorre é a falta do vínculo, ou vínculo incorreto, entre o usuário e o local informado no pedido.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Pesquisar na tabela de pedidos, usando o número do pedido na clausula WHERE;

2. Observar os campos idlocal, e idparceiro dessa consulta;

3. Realizar consulta na tabela parceirolocal usando o valor do campo idparceiro na clausula WHERE, o que mostrará todos os locais registrados para esse cliente, inclusive o informado no pedido;

4. usando o valor do campo idlocal obtido na primeira consulta citada na clausula WHERE, realizar consulta na tabela usuariolocal;

5. Se essa última consulta retornar vazia, significa que o usuário não tem vínculo com o local informado no pedido, e tendo em vista que esse vínculo vem direto do ERP, deverá ser feito por lá, pelo próprio cliente;

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