Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RMS - CAD - Manutenção de Entidades Alteração de TIPO

Ocorrência

mceclip2.pngAmbiente
Retail Manager System,  V12R31, V12R32.
Causa
Conforme equipe de produto existe validações do programa VABUTIPO, quando é do tipo F, C e V.

O programa bloqueia a alteração devido que estes geram nota e pode ter impacto no fiscal quando se realizar modificações direta pelo programa.

 

Solução

Seguindo o exemplo acima a solução seria:

 

nessa caso é necessário fazer a  alteração via banco do campo TIP_LOJA = F ( C ou V)  para TIP_LOJA desejado , seguindo a consulta abaixo e logo após fazer update:

Select * from AA2CTIPO WHERE TIP_CODIGO = 44418 AND TIP_DIGITO = 9 AND TIP_LOJ_CLI = F;

Atenção : Conforme dito acima após trazer a consulta deve fazer um update alterando o campo TIP_LOJ_CLI  de F para o tipo desejado, o único campo que deve ser modificado é esse, não esquecer do commit.


Select * from AA2CTIPO WHERE TIP_CODIGO = 44418 AND TIP_DIGITO = 9 AND TIP_LOJ_CLI = F(C ou V) FOR UPDATE;

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _