FAQs - Suporte técnico

TOTVS RH - Linha RM - SMT - Ao enviar evento S-2220 para o TAF ocorre o erro: "Cannot insert duplicate key row in object 'dbo.C9W990'"

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao enviar evento S-2220 para o TAF está ocorrendo o erro:

Cannot insert duplicate key row in object 'dbo.C9W990' with unique index 'C9W990_UNQ'. The duplicate key value is (01, 000001, 30112103868356, 20211015, 001424 , 0).


Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Segurança e Saúde Ocupacional – A partir da 12.1.31 e superiores

Causa
Conforme leiaute do evento S-2220 no eSocial, o grupo <exame> possui como chave os campos <dtExm> <procRealizado>, portanto não é possível informar o mesmo procedimento em dois exames diferentes na mesma data. 

mceclip0.png

 



Solução
A orientação é localizar junto à tabela 27 do eSocial se há algum outro procedimento mais adequado relacionado ao exame que foi inserido, para que não hajam códigos de procedimentos iguais na mesma data.  

Entendemos a situação, porém é uma limitação do leiaute, será necessário abertura de uma demanda junto ao governo para validar qual seria o procedimento a ser realizado em uma situação que ocorra dois exames com a mesma classificação da tabela 27.

Mais
TOTVS RH - Linha RM - SMT - Dúvidas frequentes sobre a geração do eventos de SST para o eSocial

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _