Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT - type mismatch on $ on XFCIGETORIGEM(FCIXFUN.PRW)


time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao incluir um pedido de devolução, o sistema gera o erro:

 type mismatch on $  on XFCIGETORIGEM(FCIXFUN.PRW) 15/09/2020 13:41:10 line : 378


Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT- Todas as versões

Causa
O erro informa que existe um tipo incompatível entre as variáveis cEstado e cUfNwPrd, cEstado recebe a informação do parâmetro mv_estado e cUfNwPrd recebe a informação do parâmetro MV_FCINWPR.

Conforme a stack do erro, cEstado está recebendo um valor lógico e não o valor atribuído no mv_estado, gerando incompatibilidade, necessário verificar se o parâmetro está cadastrado corretamente:

STACK XFCIGETORIGEM(FCIXFUN.PRW) 15/09/2020 13:41:10

  Param 1: CCODPROD(C) : N87169090-302 
  Param 2: DDTEMISSAO(D) : 2021/11/25
  Local 1: CCODPROD(C) :N87169090-302 
  Local 2: DDTEMISSAO(D) :2021/11/25
  Local 3: CPERIOD(C) :112021
  Local 4: CORIGEM(C) :
  Local 5: CFCICOD(C) :
Local 6: CESTADO(L) :.F.---->valor lógico .F. --variável recebe conteúdo do mv_estado que não é do tipo lógico.
Local 7: CUFNWPRD(C) :SP---> recebendo o estado
  Local 8: NCONT(N) :0
  Local 9: DDATACALC(D) :00/00/00
  Local 10: CFILIALCFD(C) :06


Solução

Para solucionar essa ocorrência, certifique-se que os parâmetros estejam configurados conforme abaixo:

mceclip0.png

mceclip1.png

 

Caso não estejam, exclua e inclua novamente com esta configuração ou baixe o dicionário de dados e rode o upddistr para que o ajuste seja efetuado.


O mv_estado e o mv_fcinwpr precisam ser do mesmo tipo caráter para que comparação possa passar e não gerar conflitos.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _