Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - SIGAFAT - TES Inteligente duplica o financeiro Vtex x Protheus

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao utilizar o TES Inteligente em um pedido de venda incluído pelo Vtex, o sistema esta gerando os títulos novamente, fazendo com que o financeiro fique duplicado.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Faturamento (SIGAFAT) - Todas as versões

Causa
O TES utilizado na venda pelo Vtex é informado no parâmetro MV_LJTESPE, esse TES não deve gerar movimento financeiro, campo "Gera Dupl." (F4_DUPLIC) igual a "Não". Pois o financeiro é gerado pelas rotinas de varejo (GravaBatch) no momento que o pedido é criado, colocando para não gerar, não será gerado no momento que o pedido for faturado no módulo de faturamento.

Para utilização da TES Inteligente, onde o Pedido gerado no Loja deverá gerar financeiro e o Pedido gerado no Faturamento não deverá gerar, o TOTVS Connector deve enviar o tipo de operação (tag OperationCode) diferente de "V".  Para seguir o padrão do Loja, enviar a tag com "01".


Solução
Para evitar a Duplicidade na geração do Financeiro no processo de integração do Vtex com o Protheus:

1. O TES informado no parâmetro MV_LJTESPE não deve gerar Financeiro "Gera Dupl." (F4_DUPLIC) igual a "Não";

2. O TES sugerido pelo TES Inteligente, também não deve gerar financeiro "Gera Dupl." (F4_DUPLIC) igual a "Não";

O Título será gerado pela rotina automática do SIGALOJA (GravaBatch), os demais movimentos executados no sistema não devem conter movimentação financeira.

 

Saiba mais: Guia de uso - Integração do Pedido Loja(Venda Assistida) com VTEX

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _