FAQs - Suporte técnico

RH - Linha Protheus - MDT - No processo de exclusão de um Risco, retorna a mensagem: HELP: NGINTMOD.


time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
No processo de exclusão de um Risco, após entrar na rotina MTDA180 e clicar em Outras Ações > Excluir, retorna a mensagem: HELP: NGINTMOD. Problema: Exclusão não permitida. Existe registro em outro arquivo que utiliza esta informação. Solução: Verificar integridade da informação no arquivo citado acima.

Ambiente
TOTVS RH (Linha Protheus) - Medicina e Segurança do Trabalho – Todas as versões

Causa
Ocorre esta mensagem quando o risco possui relacionamentos com algumas tabelas, como:  Epc x Riscos (TO9); Epi x Riscos (TNX); Exames por Risco (TN2). Então quando tenta realizar a exclusão o sistema informa que aquela informação é utilizada por alguma tabela e não permite continuar o processo.

Solução

Para que a exclusão seja efetuada com sucesso, é necessário que o risco não possua relacionamentos com as seguintes tabelas:

  • Acidentes de Trabalho (TNC)
  • Epc x Riscos (TO9)
  • Epi x Riscos (TNX)
  • Exames por Risco (TN2)
  • Histórico de Avaliações (TGD)
  • Laudos x Riscos (TO1)
  • Nível Organizacional (TAF)
  • Plano de Ação por Risco (TNJ)
  • Requisito x Necessidades (TOA)
  • Resultado Avaliação (TG6)
  • Risco x Medida de Controle (TJF)
  • Riscos ASO (TMX)
  • Riscos x Produtos Químicos (TJD)
  • Riscos da Permissão (TI2)
  • Treinamento por Necessidade (TY4)

Para verificar se o risco está relacionado com algumas das tabelas acima poderá entrar na rotina de Risco em  Outras Ações > Relacionamentos ou no menu Atualizações > PPRA > Relacionamentos, após acessar um desses caminhos, verifique na parte inferior em todas as abas se existe alguma informação relacionada, clica no registro e aperte delete.

Conforme GIF abaixo:

3cBSFZOiud.gif


Saiba Mais

Artigos sobre Medicina e Segurança do Trabalho

MDT - PPRA

Riscos (MDTA180 - SIGAMDT)

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _