Tempo aproximado para leitura: 00:02:00 min
Ocorrência
Ao gerar a cópia do Pedido de Vendas e clicar em salvar, o sistema apresenta o erro:
array out of bounds ( 0 of 115 ) on A410BLQREG(MATN410.PRW)
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT - Todas as versões
Causa
Erro de array out of bounds ocorre quando algum campo do array não existe no dicionário de dados (sx3), não está como usado ou teve seu nível mudado de 1.
Neste erro, o array está apontando para o campo c6_descont, que pode ser que esteja com o uso demarcado ou com o nível diferente de 1.
Dentro deste array, também fazem parte os campos: c6_prunit, c6_prcven, c6_produto e c6_item.
Solução
Para solucionar:
1- Acessar o moduloSIGACFG - Configurador→ Base de Dados → Dicionário → Base de Dados;
2 - Pesquisar a tabela SC6 e buscar pelo campo c6_descont;
3 - Alterar o campo ,selecionar a ABA USO, deixar o campo como USADO e o nível de campo igual 1.
4 - Salvar o campo, salvar a tabela e atualizar o dicionário de dados.
5 - Reinicie o smartclient e efetue o procedimento novamente.
Obs: caso ajustando o c6_descont, o problema permaneça, valide os demais campos que pertencem ao array (c6_prunit, c6_prcven, c6_produto e c6_item) , ajustando conforme as orientações acima.
0 Comentários