Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Logix - BI - Horário do agendamento incorreto

time.png Tempo aproximado para leitura: 01:56:00 min

Ocorrência

Horário do agendamento incorreto em período do horário de verão.

Ambiente
Framework - Framework (Linha Logix) - Inteligência Empresarial (BI) - Versão 12

Causa
O servidor está considerando o horário de verão e o mesmo não está vigente.

Solução
1. Execute o Serviços do Windows;
2. Localize o serviço do Tomcat utilizado pelo produto Logix BI - Business Intelligence;
3. Acesse as Propriedades do serviço e verifique os campos Nome do Serviço e Caminho do Executável;
4. Execute o cmd - Prompt de Comando do Windows;
5. Navegue até o diretório constante no Caminho do Executável obtido no passo 3.
Ex.: C:\totvsbi11\tomcat\tomcat8.0.33\bin;
6. Digite o comando tomcat8w.exe //ES/[NOME DO SERVIÇO], respeitando o sentido das barras.
Ex.: tomcat8w.exe //ES/tomcat8;
7. Na tela que se abrirá, clique na aba Java;
8. Em Java Options: acrescente o parâmetro abaixo:

-Djava.net.preferIPv4Stack=true 
-Duser.country=BR
-Duser.language=pt

-Duser.Timezone=America/Bahia

Sem_t_tulo.png

E no arquivo: C:\totvsbi11\tomcat\configuracao8.bat acrescentar a linha:

set JAVA_OPTS=%JAVA_OPTS% -Duser.language=pt -Duser.region=BR -Duser.timezone=America/Bahia

Exemplo:

222.png

Após os passos acima, reinicie o Tomcat para que seja instanciado com os parâmetros informados.

Saiba mais
Java possui um DST Dayligth Saving Time próprio e nesse caso é necessário atualizar o seu banco de dados local com as informações de TimeZone mais recentes em Framework - Linha Datasul - TEC - Java com horário de verão incorreto

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _