FAQs - Suporte técnico

RH - Linha Protheus - MDT - Ao acessar a rotina de Cadastro de EPC é apresentado error log - InterFunctionCall: cannot find function CHKDTGARAN

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao acessar a rotina de Cadastro de EPC (Equipamento de Proteção Coletivo), através da rotina MNTA080, é apresentado error log: "InterFunctionCall: cannot find function CHKDTGARAN in AppMap on {|a,b,c| FWInitCpo(a,b,c),lRet:=(CHKDTGARAN()),FWCloseCpo(a,b,c,lRet,.T.),lRet }(PROTHEUSFUNCTIONMVC.PRX)"

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Medicina e Segurança do Trabalho - Todas as versões

Causa
Este erro ocorre devido às propriedades do campo T9_DTGARAN utilizar a função de nome CHKDTGARAN

Solução
1. 
Acessar o Módulo de Configurador;
2. Acessar a rotina Base de Dados -> Dicionário -> Base de Dados;
3. Expandir as opções da Empresa e selecionar a opção Tabelas;
4. Posicionar sobre a tabela ST9 e acessar com a opção Alterar;
5. Expandir as opções da Tabela e selecionar a opção Campos;
6. Sobre o campo T9_DTGARAN, selecionar a opção Alterar e deixar as propriedades como demonstrado abaixo:


7. Salvar as alterações;
8. Testar entrar na rotina novamente.

Informações complementares
Pacote de Expedição Contínua do RH: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854 
Pacote de Expedição Contínua do eSocial: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854 
Pacote de Expedição Contínua do Medicina e Segurança do Trabalho: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057956773 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _