Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - SIGAFAT - Array out of bounds ( 0 of 74 ) on A410MULTT(MATV410A.PRW)


time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao tentar incluir ou alterar o campo C6_PRCVEN, o sistema gera error.log, conforme o anexo abaixo:

mceclip0.png

mceclip1.png

Ambiente
Cross Segmentos-TOTVS Backoffice (Linha Protheus)-SIGAFAT- Todas as versões.

Causa

Erro de array out of bound indica que o programa está tentando acessar uma posição de array à qual não existe.

A causa pode estar relacionada a algum campo não localizado, devido a:

  • Não possuir no dicionário / na base;
  • Não estar devidamente marcado como usado;
  • Não estar marcado como visível para o módulo em questão;
  • Estar configurado com nível de campo superior ao disponível para o usuário;

Outras causa possíveis:

  • Alguma customização influenciando no processo (quando há customizações por ponto de entrada ou mesmo nos dicionários);
  • Ou alguma chamada indevida no fonte à uma posição de array inexistente.

Para este caso, o problema é que o campo C6_DESCONT não localizado pela função podendo estar relacionado a alguma das opções de causa de campo acima.

O erro também pode ocorrer, caso o campo C6_VALDESC não seja localizado pela função, podendo estar relacionado a alguma das opções de causa mencionadas acima.

 

Solução

Para solucionar:

1- Acessar o modulo SIGACFG - Configurador → Base de Dados → Dicionário → Base de Dados;

2 - Pesquisar a tabela SC6 e buscar pelo campo C6_DESCONT ou C6_VALDESC  ;

3 - Alterar o campo ,selecionar a ABA (USO), deixar o campo como  USADO e  o nível de campo igual 1.

4 - Salvar o campo, salvar a tabela e atualizar o dicionário de dados.

5 - Reinicie o smartcliente e efetue o procedimento novamente.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _