Tempo aproximado para leitura: 00:02:00 min
Ocorrência
Ao tentar incluir ou alterar o campo C6_PRCVEN, o sistema gera error.log, conforme o anexo abaixo:


Ambiente
Cross Segmentos-TOTVS Backoffice (Linha Protheus)-SIGAFAT- Todas as versões.
Causa
Erro de array out of bound indica que o programa está tentando acessar uma posição de array à qual não existe.
A causa pode estar relacionada a algum campo não localizado, devido a:
- Não possuir no dicionário / na base;
- Não estar devidamente marcado como usado;
- Não estar marcado como visível para o módulo em questão;
- Estar configurado com nível de campo superior ao disponível para o usuário;
Outras causa possíveis:
- Alguma customização influenciando no processo (quando há customizações por ponto de entrada ou mesmo nos dicionários);
- Ou alguma chamada indevida no fonte à uma posição de array inexistente.
Para este caso, o problema é que o campo C6_DESCONT não localizado pela função podendo estar relacionado a alguma das opções de causa de campo acima.
O erro também pode ocorrer, caso o campo C6_VALDESC não seja localizado pela função, podendo estar relacionado a alguma das opções de causa mencionadas acima.
Solução
Para solucionar:
1- Acessar o modulo SIGACFG - Configurador → Base de Dados → Dicionário → Base de Dados;
2 - Pesquisar a tabela SC6 e buscar pelo campo C6_DESCONT ou C6_VALDESC ;
3 - Alterar o campo ,selecionar a ABA (USO), deixar o campo como USADO e o nível de campo igual 1.
4 - Salvar o campo, salvar a tabela e atualizar o dicionário de dados.
5 - Reinicie o smartcliente e efetue o procedimento novamente.
0 Comentários