FAQs - Suporte técnico

Cross Segmento - TOTVS Backoffice (Linha Protheus) - ADVPL - Função StaticCall() não compila/mudou o comportamento

Ocorrência
Utilizo a função StaticCall() mas não está compilando ou teve seu comportamento alterado.

Ambiente
Cross Segmento - TOTVS BackOffice (Linha Protheus) – ADVPL – A partir da versão 12.1.33

Causa
Funções, classes e variáveis restritas em fontes customizados não estão previstas pelo suporte padrão, dado ao fato de que as mesmas não estão documentadas, assim sendo, podem vir a ser descontinuadas ou sofrer alterações de comportamento sem prévio aviso.

A função STATICCALL() é de uso interno e restrito, para ações específicas, por isso não existe documentação oficial sobre ela ou recomendação de uso da mesma.

 

Solução
Se uma função foi criada com o escopo de STATIC FUNCTION, ela foi pensada inicialmente para ter o escopo de uso somente no fonte em que está criada, e não no sistema todo.
Se esta utilizando STATICCALL() para chamadas de funções estáticas de customizações, a solução é trocar o escopo da função chamada pela STATICCALL() de STATIC FUNCTION para USER FUNCTION, assim ela pode ser usada em qualquer ponto do sistema através do uso de U_<função>.

Saiba mais
Cross Segmento - TOTVS Backoffice (Linha Protheus) - ADVPL - Funções, classes e variáveis de propriedade interna

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _