Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - JBoss do Datasul não inicializa com Oracle 12

time.png Tempo aproximado para leitura: 00:01:10 min

Ocorrência
Na inicialização do JBoss utilizando o Oracle 12 é registrado o erro no log:
Throwable while attempting to get a new connection: null org.jboss.resource.JBossResourceException: Could not create connection; - nested throwable: (java.sql.SQLException: ORA-28040: No matching authentication protocol


Ambiente
Framework - Framework (Linha Datasul) - JBoss - Todas as versões

Causa
Utilização de um driver JDBC antigo para conexão com o banco Oracle.

Solução
Será necessário atualizar o driver JDBC - Java Database Connectivity do JBoss, conforme procedimento:

1. Realize o download do arquivo ojdbc7.jar disponibilizado no Anexo desse artigo;

2. No Servidor do JBoss, no diretório lib, exclua o arquivo ojdbc6.jar. Exemplo de caminho para o diretório libc:\totvs\datasul\ServidorAplicacao\jboss-4.2.3.GA\server\instance-8080\lib;

3. Copie o arquivo ojdbc7.jar para o diretório lib;

4. Elimine os diretórios temporários do JBoss: data, log, tmp e work;

5. Reinicie o JBoss.


Anexo

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _