FAQs - Suporte técnico

RH - Linha Protheus - TCF - Erro ao alterar o cadastro de usuário genérico - array out of bounds ( 0 of 0 ) on {|a,b,c| FWInitCpo(a,b,c),xRet:=(IIF(!INCLUI .AND. !EMPTY(ACOLS[LEN(ACOLS)][2]),POSICIONE("SA1",1,XFILIAL("SA1")+AI4->AI4_CODCLI+AI4->AI4_LOJC

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao Alterar um cadastro de usuário genérico, através da rotina FATA220, gera error log: "array out of bounds ( 0 of 0 ) on {|a,b,c| FWInitCpo(a,b,c),xRet:=(IIF(!INCLUI .AND. !EMPTY(ACOLS[LEN(ACOLS)][2]),POSICIONE("SA1",1,XFILIAL("SA1")+AI4->AI4_CODCLI+AI4->AI4_LOJCLI,"A1_NOME"),"")),FWCloseCpo(a,b,c,.T.),FwSetVarMem(a,b,xRet),xRet }(PROTHEUSFUNCTIONMVC.PRX)"

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Terminal de Consulta do Funcionário - Todas as versões

Causa
O erro ocorre por se tratar de inconsistência no inicializador padrão do campo AI4_NOMCLI

Solução
Para solução do problema, será necessário alterar o inicializador do campo AI4_NOMCLI, conforme abaixo:
1. Entre no Configurador (SIGACFG);
2. Acesse a rotina Base de dados>dicionários>base de dados:
mceclip0.png

3. Clique no '+' para expandir a árvore da empresa e clique em dicionário de dados:
mceclip1.png
4. Procure a tabela AI4 e edite:
mceclip2.png
mceclip4.png

5. Selecione o campo AI4_NOMCLI e edite:
mceclip5.png

6. Na aba opções, será necessário efetuar a correção do inicializador padrão do campo:
De: IIF(!INCLUI .AND. !EMPTY(ACOLS[LEN(ACOLS)][2]),POSICIONE("SA1",1,XFILIAL("SA1")+AI4->AI4_CODCLI+AI4->AI4_LOJCLI,"A1_NOME"),"")

Para: IIF(!INCLUI .AND. !EMPTY(AI4->AI4_CODCLI),POSICIONE("SA1",1,XFILIAL("SA1")+AI4->AI4_CODCLI+AI4->AI4_LOJCLI,"A1_NOME"),"")   

mceclip6.png

Informações complementares
Pacote de Expedição Contínua do Medicina e Segurança do Trabalho: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057956773 
Pacote de Expedição Contínua do Gestão de Pessoal conforme abaixo:
https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854 
Pacote de Expedição Contínua do eSocial: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _