Ocorrência
No TOTVS Moda, ao tentar dar aceite no pedido é apresentada a ocorrência:

O Omni retorna o erro 500:
SITUACAO=500
CABECALHO=Date=Wed, 13 Oct 2021 13:13:47 GMT·;Server=Apache·;Connection=close·;Transfer-Encoding=chunked·;Content-Type=application/json;charset=UTF-8
CONTEUDO={"timestamp":1634130828506,"status":500,"error":"Internal Server Error","exception":"java.lang.Exception","message":"Store not found","path":"/hermesCore/rest/orders/confirmPendingAcceptByStore/idSite/578/idStore/24"}
RESPOSTA=HTTP/1.1 500 500
Ambiente
TOTVS OMNI BY MODDO - ERP Virtual Age
Causa
Loja não associada ao site principal.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse a plataforma Omni Moddo;
2. Vá em Configurações>Sites;

3. Selecione o site principal do cliente e clique em Alterar;

4. A loja deve estar associada ao site principal. Em Lojas, verifique se a loja informada na mensagem (Exemplo: Erro ao enviar aceite do pedido xxxx da empresa 024) encontra-se selecionada na coluna da direita conforme exemplo abaixo:

Obs: encontra a loja na relação da esquerda e manda pelo botão com setinhas para a coluna da direita.
5. Clique em Aceitar para salvar as alterações.

Faça um novo teste e verifique se o pedido é aceito com sucesso.
Saiba Mais
TDN TOTVS OMNI BY MODDO
0 Comentários