Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Agro - PIMS MB - MBPIMI - Regra de Negócio do apontamento no período

Agro - PIMS MB - MBPIMI - Regra de Negócio do apontamento no período

time.png Tempo aproximado para leitura: 00:03:20 min

Ocorrência
No módulo Controle Manutenção IndustrialMBPIMI, ao tentar transmitir as Rotas Finalizadas é apresentada a mensagem Verificar regra de Negócio: Já existe apontamento no período.

MBPIMI.jpg

Ambiente
TOTVS Agro - TOTVS Agro - Bioenergia - Controle Manutenção Industrial - MBPIMI - Versão 12

Causa
Esse incidente geralmente ocorre quando se tem apontamento gravado no MI - Controle Manutenção Industrial para o funcionário, data e intervalo. 

Solução
Para fazer a validação se já existe apontamento no MI, siga os passos abaixo:

1. Acesse o MI, na opção Relatórios Gerenciais;

MBPIMI1.png

2. Acesse a opção Preventiva/Preditiva > Apontamento de Mão-de-Obra;

MBPIMI2.png

3. Filtre a Data Inicial e Data Final;

MBPIMI3.png

4. Filtre a Ordem de Serviço;

MBPIMI4.png

5. Marque apenas o funcionário que deseja analisar;

MBPIMI5.jpg

6. O relatório será exibido após clicar em OK;

MBPIMI6.jpg

O check para analisar se há apontamento gravado no MI para o funcionário, data e intervalo também pode ser realizado através do select abaixo:

select f.fun_cracha, f.fun_nome, mo.*
from mcpmogasta mo, mcpfunci f
where mo.id_funci = f.id_funci
and upper(f.fun_nome) like '%NOME DO FUNCIONARIO%'
and mo.mog_data = 'XX/XX/XXXX'
order by mo.mog_data, mo.mog_horini

Caso constatado que realmente já exista apontamento para o funcionário, data e intervalo gravados no MI, seguir os passos abaixo: 

7. Acesse o aplicativo MBPIMI e escolha a opção Zerar Rotas e Ordens Sincronizadas;

MBPIMI7.png

8. Realize novamente o apontamento com os dados corretos no MBPIMI e envie o apontamento para o MI.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _