FAQs - Suporte técnico

RH - Linha Protheus - MDT - Ao incluir um Usuário SESMT é gerado error log - InterFunctionCall: cannot find function A640TESTOK

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao realizar o Cadastro de um Usuário SESMT, através da rotina MDTA070, é apresentado o error log: "InterFunctionCall: cannot find function A640TESTOK in AppMap on {|x| Self:lActive  .and. A640TESTOK()                                                }(MSMGETPR.PRW)"

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Medicina e Segurança do Trabalho - Todas as versões

Causa
Este erro ocorre devido à utilização indevida da função A640TESTOK retirada do Repositório

Solução
Como a alteração que exclui a função A640TESTOK ocorreu durante a existência da versão 12.1.17, as versões seguintes iniciaram sem esta funcionalidade no Dicionário, portanto não há Dicionários Diferenciais que excluam esta função em versões superiores à 12.1.17, desta forma é necessário:
1. Acessar o Módulo de Configurador;
2. Acessar a rotina em Base de Dados/Dicionário/Base de Dados;
3. Acessar a tabela TMK como Alterar;
4. Procurar dentre os campos da tabela TMK, na propriedade "Modo Edição" (X3_WHEN), os que utilizam a função A640TESTOK e excluir o uso dessa função;
5. Salvar as alterações realizadas no Configurador;
6. Verificar que a rotina executa corretamente.

Informações complementares
Pacote de Expedição Contínua do Gestão de Pessoal: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854 
Pacote de Expedição Contínua do eSocial: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854 
Pacote de Expedição Contínua do Medicina e Segurança do Trabalho: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057956773 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _