FAQs - Suporte técnico

RH - Linha Protheus - GPE - Erro ao efetuar o calculo de rescisão - Lock Record - Ctree Error 29 - IO Error: 0 - Zero drn in data file routine File: c:\totvs\microsiga\protheus_data\system\sxuXXX.dtc

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao tentar efetuar o Cálculo de Rescisão, através da rotina GPEM040, gera o seguinte error log no console: "Lock Record - Ctree Error 29 - IO Error: 0 - Zero drn in data file routine File: c:\totvs\microsiga\protheus_data\system\sxuXXX.dtc"

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal - Todas as versões

Causa
O erro ocorre por erro na estrutura do dicionário SXU

Solução
Para solução do problema será necessário:
1. Caso o dicionário esteja no Banco de Dados:
1.1. Efetuar cópia da tabela SXUXXX (onde o "xxx" indica o código da Empresa/Grupo de Empresa mais 0), deletar a tabela e acessar o sistema para recriá-la.

2. Caso o dicionário esteja no diretório system (CTREE):
2.1. Efetuar cópia do registro SXUXXX.DTC (onde o "xxx" indica o código da Empresa/Grupo de Empresa mais 0);
2.2. Deletar o arquivo SXUXXX.CDX para que seja recriada ao entrar no sistema.

Informações complementares
Pacote de Expedição Contínua do Medicina e Segurança do Trabalho: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057956773
Pacote de Expedição Contínua do Gestão de Pessoal: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854 
Pacote de Expedição Contínua do eSocial: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _