FAQs - Suporte técnico

Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT- Argument error in function Len() on FAAVALSE1(FINXAPI.PRX) na exclusão da nota


time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao tentar excluir uma nota de Serviço, gera o error.log: argument error in function Len() on FAAVALSE1(FINXAPI.PRX)

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT- Todas as versões.

Causa

O erro argument error in function Len() on FAAVALSE1(FINXAPI.PRX) ocorre na exclusão da nota de saída (mata521), é sempre relacionado a nota de Serviços e muitas vezes é precedido do Help:

mceclip0.png

A rotina pai da função FA040PENC é o FINA040, um dos motivos de ocorrer a mensagem seria a falta da função FA040PENC para poder concluir o processo. Como esta função já está declarada no FINA040, a outra possibilidade é que a função FAAVALSE1 que pertence ao FINXAPI esteja mais atualizada em relação ao FINA040.

Solução

Para solucionar essa ocorrência, realize os seguintes passos:
1. Efetue o download do pacote de expedição contínua do módulo financeiro, relacionado a release utilizada: Pacotes de Atualização - Financeiro - P12 
2. Via Vs-Code, aplique a atualização, primeiramente em base de homologação para validar e posteriormente, em base de produção. 
3.Após a atualização, reinicie o smartclient e refaça o processo.

Obs: O tratamento indicado  requer conhecimento técnico de Vs-Code, caso necessite de apoio mais técnico, contate a equipe de Advpl.

Clientes Cloud, solicite a equipe de Atendimento Cloud para efetuar a atualização no ambiente.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _