Ocorrência
Ao tentar ativar a licença do RMS no programa LicMgrCli o servidor de aplicação(RMSSRV) apresenta a seguinte mensagem: Contexto não encontrado, conforme visto na Figura 1.
Figura 1 - LicMgrCli -Administração de Licenças
Ambiente
Retail Manager System - RMS - Administração de Licença (LicMgrCli) - Todas as versões
Causa
O novo contexto não foi instalado como administrador.
Solução
Para solucionar essa ocorrência, será necessário inserir manualmente no registro do servidor da aplicação a chave do contexto.
1. Abre o Regedit e segue até o registro abaixo conforme visto na Figura2:
(HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\RMS\RMSSRV\Contextos)
Figura 2 - Regedit - Editor do Registro
2. Nessa etapa, será necessário criar uma nova chave dentro da pasta “Contextos”. Clica com o botão direito do mouse na pasta “Contextos” e seleciona “Novo” > “Chave” e coloca o nome do contexto que deseja criar, conforme exemplo na Figura 3.
Figura 3 - Regedit - Editor do Registro
3. Após a criação do novo contexto, será necessário inserir um novo registro. Clica com o botão direito do mouse na pasta que criou no passo anterior e seleciona “Novo” > “Valor de Cadeia de Caracteres” e renomeia o registro para “DirBase”, conforme exemplo na Figura 4.
Figura 4 - Regedit - Editor do Registro
4. Abre o registro “DirBase” e coloca o caminho físico do contexto de acordo com a instalação do seu produto e clica em OK para Salvar, conforme exemplo na Figura 5.
Figura 5 - Regedit - Editor do Registro
5. Após realizar todo o procedimento, realiza novamente a ativação da licença no programa (LicMgrCli) e o problema estará resolvido. Clica em “Associar” para preencher as informações da licença, conforme exemplo na Figura 6.

Figura 6 - LicMgrCli -Administração de Licenças
6. Finaliza o processo clicando em “FIM” e a licença estará associada, conforme exemplo na Figura 7.
Figura 7 - LicMgrCli -Administração de Licenças
0 Comentários